1. 程式人生 > >poj 1050 To the Max(動態規劃處理二維最大子段和)

poj 1050 To the Max(動態規劃處理二維最大子段和)

2、題目大意:

給一個N,然後給定一個N*N的二維陣列,然後求一個子矩陣,使得其中的數加起來和最大

3、思路:

將二維陣列轉換成一維陣列,假設二維陣列是M行N列,那麼將二維陣列分成N條,用dp[i]記錄第i列的和(可以是任意連續長度,for迴圈就能實現),那麼將dp[i]看做一個一個的數,就轉換成了一維的陣列

核心程式碼:

 for(int i=1;i<=n;i++)//迴圈從第一行開始,往下找,i作為每一條的起始點
    {
        memset(dp,0,sizeof(dp));
        for(int j=i;j<=n;j++)
        {
            for(int k=1;k<=n;k++)
            dp[k]+=a[j][k];//求出每一條起點是i,終點是j的長度區間的和
            int sum=maxsum(dp,n);//轉換成一維陣列後,處理就跟一位陣列的程式碼完全一樣
             if(sum>max)
             max=sum;
        }
        memset(dp,0,sizeof(dp));
    }

3、題目:

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34519 Accepted: 18104

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

4、一遍ac的程式碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[110][110];
int dp[110];
int b[110];
int maxsum(int *bb,int n)
{
    int max=-9999999;
    b[0]=max;
    for(int i=1;i<=n;i++)
    {
        if(b[i-1]>0)
        b[i]=b[i-1]+bb[i];
        if(b[i-1]<0)
        b[i]=bb[i];
        if(b[i]>max)
        max=b[i];
    }
    return max;
}
int main()
{
    int n,max=-99999999;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&a[i][j]);
        }
    }
    for(int i=1;i<=n;i++)
    {
        memset(dp,0,sizeof(dp));
        for(int j=i;j<=n;j++)
        {
            for(int k=1;k<=n;k++)
            dp[k]+=a[j][k];
            int sum=maxsum(dp,n);
             if(sum>max)
             max=sum;
        }
        memset(dp,0,sizeof(dp));
    }
    printf("%d\n",max);
    return 0;
}
/*
4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2
*/