1. 程式人生 > >lower_bound_1044 Shopping in Mars (25 分)

lower_bound_1044 Shopping in Mars (25 分)

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

題中要求找出,自區間之和與M的差最小,但必須大於等於0

所以直接作出陣列的字首和,然後使用lower_bound函式尋找和大於等於M的第一個位置

比較找出的每一個區間,捨去差較大的區間,保留較小的區間即可

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
#include <queue>
#include <vector>
#include <map>
#include <set>
#define INF 0x3f3f3f3f
#define ll long long

using namespace std;
const int maxn = 1e5+100;
int n,m;
int a[maxn];
vector<pair<int,int> > ans;

int main()
{
    int mi = INF;
    scanf("%d%d",&n,&m);
    for(int i = 1;i <= n;i ++)
        scanf("%d",a+i),a[i] += a[i-1];
    for(int i = 0;i <= n;i ++)
    {
        int pos = lower_bound(a+1,a+n+1,a[i] + m) - a;
        if(a[pos] - a[i] < m)
            break;
        if(a[pos] - a[i] < mi)
        {
            ans.clear();
            ans.push_back(make_pair(i+1,pos));
            mi = a[pos] - a[i];
        }
        else if(a[pos] - a[i] == mi)
            ans.push_back(make_pair(i+1,pos));
    }
    for(int i = 0;i < ans.size();i ++)
        printf("%d-%d\n",ans[i].first,ans[i].second);
    return 0;
}