1. 程式人生 > >stl的map2------[NWPU][2018寒假作業][通用版]二、stl ,模擬,貪心等 [Cloned]B題

stl的map2------[NWPU][2018寒假作業][通用版]二、stl ,模擬,貪心等 [Cloned]B題

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(‘\t’), enter(‘\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
Output
In this problem, you have to output the translation of the history book.
Sample Input
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i’m fiwo riwosf.
i fiiwj fnnvk!
END
Sample Output
hello, i’m from mars.
i like earth!
Hint
Huge input, scanf is recommended.

解題思路:
前面的字典部分,用map

#include<iostream>
#include<map>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;

int main()
{
    string t,m,e,tran;
    map<string,string> dict;
    while(1)
    {
        cin>>t;
        while(1)
        {
            cin
>>m; if(m=="END") { break; } cin>>e; dict[e]=m; } cin>>t; tran=""; getchar(); char sen[3010]={0}; while(1) { gets(sen); if(strcmp
(sen,"END")==0) { return 0; } int len=strlen(sen); for(int i=0;i<len;i++)//遍歷這個句子 { if(sen[i]<'a'||sen[i]>'z') //當前字元不是字母,證明單詞結束 { if(dict[tran]!="") {//如果字典中有這個單詞,輸出對應字串 cout<<dict[tran]; } else {//字典中沒有這個單詞,則輸出單詞 cout<<tran; } tran="";//情況字串,準備儲存下一個單詞 cout<<sen[i];//輸出當前不是字母的字元 } else//當前字元是字母時 { tran+=sen[i];//將字母存到字串中 } } cout<<endl; } } }