1. 程式人生 > >【杭電-oj】-2008-數值統計

【杭電-oj】-2008-數值統計

Problem Description 統計給定的n個數中,負數、零和正數的個數。
Input 輸入資料有多組,每組佔一行,每行的第一個數是整數n(n<100),表示需要統計的數值的個數,然後是n個實數;如果n=0,則表示輸入結束,該行不做處理。
Output 對於每組輸入資料,輸出一行a,b和c,分別表示給定的資料中負數、零和正數的個數。
Sample Input 6 0 1 2 3 -1 0 5 1 2 3 4 0.5 0
Sample Output 1 2 3 0 0 5
</pre><pre name="code" class="cpp">#include<stdio.h> 
int main()
{
    double n;
    double d[222];
    while(~scanf("%lf",&n)&&n)
    {
        int a=0;
        int b=0;
        int c=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%lf",&d[i]);
            if(d[i]<0)
            {
                a=a+1;
            }
            if(d[i]==0)
            {
                b=b+1;
            }
            if(d[i]>0)
            {
                c=c+1;
            }
        }
        printf("%d %d %d\n",a,b,c);
    }
    return 0;
}