1. 程式人生 > >HDU5832 A water problem【大數模除】

HDU5832 A water problem【大數模除】

A water problem

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5419 Accepted Submission(s): 1768

Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

Sample Input
10001
0
333

Sample Output
Case #1: YES
Case #2: YES
Case #3: NO

Author
UESTC

Source
2016中國大學生程式設計競賽 - 網路選拔賽

問題連結HDU5832 A water problem
問題簡述:(略)
問題分析
    這是一個大數模除問題,需要根據餘數定理進行計算。輸入的數位數很多,需要用字串陣列來儲存。
程式說明:(略)
參考連結:(略)
題記:(略)

AC的C語言程式如下:

/* HDU5832 A water problem */

#include <stdio.h>

#define MOD 10001
#define N 10000000
char s[N + 1];

int main(void)
{
    int ans, caseno = 0, i;
    while(scanf("%s", s) != EOF) {
        ans = 0;
        for(i = 0; s[i]; i++)
            ans = (ans * 10 + s[i] - '0') % MOD;

        printf("Case #%d: %s\n", ++caseno, ans ? "NO" : "YES");
    }

    return 0;
}