1. 程式人生 > >【PAT】1089. Insert or Merge (25)

【PAT】1089. Insert or Merge (25)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort

1 2 3 8 4 5 7 9 0 6

題意:給出倆個數組,一個是初始陣列origin,另一個是經過某種排序後的陣列sorted。判斷是採用了哪種排序的方法,並給出下一次排序後的結果。

分析:

(1)如果是插入排序,那麼排序後的陣列的前x個數字是遞增的,後n-x個數字與原來的陣列是相同的。

(2)如果判斷出是合併排序,那麼可以從初始陣列開始,採用合併排序的方式對陣列進行處理,每次處理後用vector自帶的“==”功能來比較origin是否和sorted一樣,如果一樣了,則再進行一次合併排序,輸出結果。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int N;

void show(vector<int> &vec){
	for(int i=0; i<vec.size(); i++){
		if(i==0){
			printf("%d",vec[i]);
		}else{
			printf(" %d",vec[i]);
		}
	}
	printf("\n");
}

int main(int argc, char** argv) {
	scanf("%d",&N);
	int i;
	vector<int> before(N), after(N);
	for(i=0; i<N; i++){
		scanf("%d",&before[i]);
	}
	
	for(i=0; i<N; i++){
		scanf("%d",&after[i]);
	}
	
	bool isInsert = true;
	for(i=1; i<N; i++){
		if(after[i] < after[i-1] ){
			break;
		}
	}
	int index = i;
	for(; i<N; i++){
		if(before[i] != after[i]){
			isInsert = false;
			break;
		}
	}
		
	if(isInsert){
		printf("Insertion Sort\n");
		sort(after.begin(), after.begin()+index+1);
		show(after);		
	}else{		
		int step=1, from=0, to;
		bool find = false;
		while(true){			 
			step *= 2;
			for(i=0; i*step<N; i++){
				from = i*step;
				to = ((from+step)<N)?(from+step):N;
				sort(before.begin()+from, before.begin()+to);
			}
			if(find){
				printf("Merge Sort\n");
				show(before);
				break;
			}
			if(before==after){
				find = true;
			}
		}			
	}	
	return 0;
}