1. 程式人生 > >G - Seek the Name, Seek the Fame

G - Seek the Name, Seek the Fame

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

這個題的意思就是在文字串中找一些字串,它既是文字串的字首也是文字的字尾,然後輸出他們的長度

這題是考察了KMP的一些性質,例:ababcabab ababcabab串中,ababcabab既是字首也是字尾,如果對前面ababcabab進行查詢,那麼也是對後面的ababcabab也在進行查詢操作。所以在前面求字首字尾相同時,也就保證了在總文字串中字首字尾相同

#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
const int maxn=4e5+10;
char b[maxn];
int ne[maxn];
void get(int len)
{
	int i,j=-1;
	ne[0]=-1;
	for(int i=0;i<len;)
	{
		if(j==-1||b[i]==b[j]) ne[++i]=++j;
		else j=ne[j];
	}
}
int main()
{
	while(~scanf("%s",b))
	{
		int len=strlen(b);
		get(len);
		stack<int> que;
		int i=ne[len];
		while(i>0)
		{
			que.push(i);
			i=ne[i];
		}
		while(!que.empty())
		{
			int x=que.top();
			que.pop();
			printf("%d ",x);
		}
		printf("%d\n",len);
	}
}