1. 程式人生 > >Sightseeing(最短路與次短路之和)

Sightseeing(最短路與次短路之和)

Sightseeing
Time Limit:1000MS Memory Limit:32768KB
64bit IO Format:%I64d & %I64u

Description
Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

M lines, each with three integers A, B and L, separated by single spaces, with 1 ≤ A, B ≤ N, A ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.

The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

One line with two integers S and F, separated by a single space, with 1 ≤ S, F ≤ N and S ≠ F: the starting city and the final city of the route.

There will be at least one route from S to F.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 10^9 = 1,000,000,000.

Sample Input
2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

Sample Output
3
2
題目大意:
有n個景點,給出起點與終點,求最短路和比最短路多1的路徑總數。
分析:此處用dij演算法求最短路與次短路,將dij演算法加以修改即可,用二維陣列,一個記錄最短路的情況,一個記錄次短路的情況,由於此處有重邊,dij的存圖方法不能處理重邊,所以用鄰接表來存圖。
程式碼:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<cstring>
#include<cstdio>
#define inf 0x3f3f3f3f
#define maxn 1005
using namespace std;
struct node
{
   int en;
   int len;
   int next;
};
node E[maxn*10];
int dis[maxn][3];//dis[maxn][1]為最短路,dis[maxn][2]為次短路
bool vis[maxn][3];
int num[maxn][3];//記錄最短路與次短路的條數
int head[maxn];
int num1;
int n,m;
void add(int st,int en,int len)
{
    E[num1].en=en;
    E[num1].len=len;
    E[num1].next=head[st];
    head[st]=num1++;
}
void dij(int st,int en)
{
    int i,j,mark,minn,flag;
    dis[st][1]=0;
    memset(num,0,sizeof(num));
    num[st][1]=1;
    for(i=1;i<=2*m-1;i++)
    {
        minn=inf;
        for(j=1;j<=n;j++)
        {
            if(!vis[j][1]&&dis[j][1]<minn)
            {minn=dis[j][1];mark=j;flag=1;}
            else if(!vis[j][2]&&dis[j][2]<minn)
            {minn=dis[j][2];mark=j;flag=2;}
        }
        if(minn==inf)//如果找不到最短路與次短路,跳出迴圈
        break;
        vis[mark][flag]=true;
        for(i=head[mark];i!=-1;i=E[i].next)
            {
                 int ed=E[i].en;
                 if(dis[ed][1]>minn+E[i].len)//找到的邊比最短路短,更新最短路與次短路及其條數
                 {
                     dis[ed][2]=dis[ed][1];
                     dis[ed][1]=minn+E[i].len;
                     num[ed][2]=num[ed][1];
                     num[ed][1]=num[mark][flag];
                 }
                 else if(dis[ed][1]==minn+E[i].len)//找到的邊與最短路相等,更新最短路的條數
                 {
                     num[ed][1]+=num[mark][flag];
                 }
                 else if(dis[ed][2]>minn+E[i].len)//找到的邊與比次短路短,更新次短路及其條數
                 {
                     dis[ed][2]=minn+E[i].len;
                     num[ed][2]=num[mark][flag];
                 }
                 else if(dis[ed][2]==minn+E[i].len)//找到的邊與次短路相等,更新次短路的條數
                 {
                     num[ed][2]+=num[mark][flag];
                 }
            }
    }
    if(dis[en][1]+1==dis[en][2])//如果次短路比最短路多1,輸出其總數
    printf("%d\n",num[en][1]+num[en][2]);
    else
    printf("%d\n",num[en][1]);
}
int main()
{
    int i,j,t,k,a,b,l,s,f;
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        num1=0;
        memset(head,-1,sizeof(head));
        memset(vis,false,sizeof(vis));
        memset(dis,inf,sizeof(dis));
        scanf("%d%d",&n,&m);
        for(j=1;j<=m;j++)
        {
            scanf("%d%d%d",&a,&b,&l);
            add(a,b,l);
        }
        scanf("%d%d",&s,&f);
        dij(s,f);
    }
    getchar();
    getchar();
    return 0;
}