1. 程式人生 > >HDU 1698 Just a Hook(線段樹的區間更新)

HDU 1698 Just a Hook(線段樹的區間更新)

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24.

先給出點的個數
後來給出要更新的區間的個數。後來給出要更新的區間和要把次區間變為的值。
在這裡面較難的問題為區間的更新,要判斷某的區間是不是雜色的問題。

下面是AC程式碼:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;

struct node
{
    int left,right,val;
} c[300005];

void build_tree(int l,int r,int root)
{
    c[root].left=l;
    c[root].right=r;
    c[root].val=1;
    if(l!=r)
    {
        int mid=(c[root].left+c[root].right)/2;
        build_tree(l,mid,root*2);
        build_tree(mid+1,r,root*2+1);
    }
}

int search_tree(int root)
{
    if(c[root].val!=-1)//如果不雜色,那麼這個區間內每個點的值都是一樣的
    {
        return (c[root].right-c[root].left+1)*c[root].val;
    }
    else return search_tree(root*2)+search_tree(root*2+1);//如果雜色的話,區間內每個點的值不一定一樣,所以要從左右兒子求起
}

void update_tree(int l,int r,int root,int x)
{
    if(c[root].val==x)
    {
        return;
    }
    if(c[root].left==l&&c[root].right==r)
    {
        c[root].val=x;
        return ;
    }
    if(c[root].val!=-1)
    {
        c[root*2].val=c[root*2+1].val=c[root].val;
        c[root].val=-1;//如果不雜色的話,標記為雜色
    }
    int mid=(c[root].left+c[root].right)/2;
    if(mid<l)
    {
        update_tree(l,r,root*2+1,x);
    }
    else if(mid>=r)
    {
        update_tree(l,r,root*2,x);
    }
    else
    {
        update_tree(l,mid,root*2,x);
        update_tree(mid+1,r,root*2+1,x);
    }
}

int main()
{
    int t,iCase=0,n,m,a,b,cost;
    scanf("%d",&t);
    while(t--)
    {
        iCase++;
        scanf("%d",&n);
        build_tree(1,n,1);
        scanf("%d",&m);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&a,&b,&cost);
            update_tree(a,b,1,cost);
        }
        printf("Case %d: The total value of the hook is %d.\n",iCase,search_tree(1));
    }
    return 0;
}