1. 程式人生 > >hdu 5984

hdu 5984

Pocky

Problem Description
Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

Input
The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

Output
For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

Sample Input
6
1.0 1.0
2.0 1.0
4.0 1.0
8.0 1.0
16.0 1.0
7.00 3.00

Sample Output
0.000000
1.693147
2.386294
3.079442
3.772589
1.847298

現場賽的時候,先是我看錯了一波題意,沒求出來怎麼出的樣例。模擬了好多發,沒有結果,於是交給隊友,自己去搞了B題。後來隊友看了一發,問了句1/(1+x)積分是多少,另一個隊友答ln(1+x),於是順利猜出答案。
題意嘛:給定一個長度為L的木棒,每次可以擷取最長位D的長度,當剩下長度<=d的時候擷取結束,要求達到要求所需要的擷取次數的期望。

先碼這邊,看看書學習學習之後再來。

#include<bits/stdc++.h>
using namespace std;
int main(){
    int T;
    double a,b;
    scanf("%d",&T);
    while(T--){
        scanf("%lf%lf",&a,&b);
        if(a<=b)
            printf("0.000000\n");  
        else
            printf("%.6lf\n",log(a/b)+1);
    }
    return 0;
}