1. 程式人生 > >HDU 1241 Oil Deposits DFS 水題 基礎練習

HDU 1241 Oil Deposits DFS 水題 基礎練習

Find a way
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4360    Accepted Submission(s): 1466

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 
Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’    express  yifenfei initial position.
‘M’      express  Merceki initial position.
‘#’    forbid road;
‘.’     Road.
‘@’   KCF
 
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.


Sample Input
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5
[email protected]
.#... .#... @..M. #...#


Sample Output
66 88 66
 
Author
yifenfei
 
Source

奮鬥的年代

題意:計算一大片面積中油田連通塊的個數,連通的概念(8個方向中有一個相連則這2個油田為一個塊)。

思路:DFS基礎

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<memory.h>
using namespace std;

char a[101][101];
bool vis[101][101];
int sum;
int n,m;
int dir[8][2]={-1,-1,-1,0,-1,1,0,-1,0,1,1,-1,1,0,1,1};

void dfs(int i,int j)
{
    vis[i][j]=false;
    for(int k=0;k<8;k++)
    {
        int ii,jj;
        ii=i+dir[k][0];
        jj=j+dir[k][1];
        if(a[ii][jj]=='@'&&ii>=0&&ii<n&&jj>=0&&jj<m&&vis[ii][jj])
            dfs(ii,jj);
    }
}

int main()
{
    int i,j;
    while(scanf("%d%d%*c",&n,&m)!=EOF)
    {
        if(m==0)
            break;
        for(i=0;i<n;i++)
            scanf("%s",a[i]);
        memset(vis,true,sizeof(vis));
        sum=0;
        for(i=0;i<n;i++)
        for(j=0;j<m;j++)
        {
            if(a[i][j]=='@'&&vis[i][j])
            {
                sum++;
                dfs(i,j);
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}