1. 程式人生 > >Largest prime factor(最大素數因子)

Largest prime factor(最大素數因子)

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6106 Accepted Submission(s): 1876
Problem Description Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
Input Each line will contain one integer n(0 < n < 1000000).
Output Output the LPF(n).
Sample Input
1
2
3
4
5
Sample Output
0
1
2
1
3
 給出一個數,求其最大質因數所在全體素數的第幾位
#include<stdio.h>
int a[1000010],b[1000001];
int main()
{a[0]=1;
a[1]=1;
int k=1;
for(int i=2;i<1000010;i++)
{if(a[i]==0)
{b[i]=k++;//定位
	for(int j=i;j<1000010;j=j+i)
	a[j]=i;//最大素數因子
}
}
b[1]=0;
int n,sum;
while(~scanf("%d",&n))
{
	printf("%d\n",b[a[n]]);
}
	
}