1. 程式人生 > >The Frog's Games HDU

The Frog's Games HDU

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).InputThe input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.OutputFor each case, output a integer standing for the frog's ability at least they should have.Sample Input
6 1 2
2
25 3 3
11 
2
18
Sample Output
4

11

      可以二分青蛙每次的最小跳躍距離。關鍵在於如何判斷這個距離符合題目條件。當青蛙跳躍距離固定時,一次跳儘量多的石頭,記錄跳的次數,跳躍次數小於等於m則符合條件。

#include <iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=500005;
int a[maxn];
int len,m,n;
int mmax;
int judge(int d)
{
    int last=0;
    int cnt=0;
    for(int i=0;i<=n;)
    {
        if(a[i]<=last+d)i++;
        else
        {
            if(last==a[i-1])return 0;                       //如果上次跳到的位置上一塊判斷的石頭相等,說明跳不過去了
            else
            {
                last=a[i-1];                     //可以跳到上一塊,即最遠滿足條件的石頭了
                cnt++;
            }
        }
    }
    cnt++;
    if(cnt<=m)return 1;
    else return 0;
}
int erfen()
{
    int l,r,m;
    l=1,r=len;
    int ans=0;
    while(l<=r)
    {
        m=(l+r)/2;

        if(judge(m))
        {
           r=m-1;
           ans=m;

        }
        else l=m+1;
    }
    return ans;
}
int main()
{
   // int len,m,n;
    while(cin>>len>>n>>m)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
       a[n]=len;

        cout<<erfen()<<endl;
    }
    return 0;
}