1. 程式人生 > >7-8 File Transfer (25 分)(c++)(並查集)

7-8 File Transfer (25 分)(c++)(並查集)

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤10​4​​), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k

 components." where k is the number of connected components in this network.

Sample Input 1:

5

C 3 2

I 3 2

C 1 5

I 4 5

I 2 4

C 3 5

S

Sample Output 1:

no

no

yes

There are 2 components.

Sample Input 2:

5

C 3 2

I 3 2

C 1 5

I 4 5

I 2 4

C 3 5

I 1 3

C 1 5

S

Sample Output 2:

no

no

yes

yes

The network is connected.

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <stack>
#include <cmath>
using namespace std;
const int maxn=10010;
vector<int> father(maxn,-1);
int findFather(int n){
    if(father[n]==-1) return n;
    else{
        int f=findFather(father[n]);
        father[n]=f;
        return f;
    }
}
void uni(int a,int b){
    int fa=findFather(a);
    int fb=findFather(b);
    if(fa!=fb) father[fa]=fb;
}
void check(int a,int b){
    if(findFather(a)==findFather(b)) cout<<"yes"<<endl;
    else cout<<"no"<<endl;
}
int main()
{
    int n,cnt=0;
    cin>>n;
    char s;
    cin>>s;
    while(s!='S'){
        int a,b;
        cin>>a>>b;
        if(s=='C'){
            check(a, b);
        }else if(s=='I'){
            uni(a,b);
        }
        cin>>s;
    }
    for(int j=1;j<=n;j++){
        if(father[j]==-1) cnt++;
    }
    if(cnt==1) cout<<"The network is connected."<<endl;
    else cout<<"There are "<<cnt<<" components."<<endl;
    return 0;
}