1. 程式人生 > >PAT甲級真題——1008 Elevator (20 分)

PAT甲級真題——1008 Elevator (20 分)

1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

題目大意:

電梯按照指令上下移動,向上每層6秒,向下每層4秒,每次停下5秒。

題目解析:

按照題意實現即可,注意可能有相鄰數字相同的情況。

具體程式碼:

#include<iostream>

using namespace std;

int main()
{
    int n,now_floor=0,next_floor,time=0;
    cin>>n;
    while(n--){
    	cin>>next_floor;
    	if(next_floor>now_floor)//上樓
		{
			time+=(next_floor-now_floor)*6+5;
			now_floor=next_floor;
		}
    	else if(next_floor<now_floor)
    	{
			time+=(now_floor-next_floor)*4+5;
			now_floor=next_floor;
		}
		else
			time+=5;
	}
	cout<<time;
    return 0;
}