1. 程式人生 > >1067 Sort with Swap(0, i) (25 分)(貪心,環)

1067 Sort with Swap(0, i) (25 分)(貪心,環)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}

Swap(0, 3) => {4, 1, 2, 3, 0}

Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10

5

) followed by a permutation sequence of {0, 1, ..., N

−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10

3 5 7 2 6 4 9 0 8 1

Sample Output:

9

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <stack>
#include <queue>
#include <cmath>
using namespace std;
int main()
{
    int n,cnt=0;
    cin>>n;
    int a[n],t[n];
    for(int i=0;i<n;i++){
        cin>>a[i];
    }
    for(int i=0;i<n;i++){
        t[a[i]]=i;
    }
    for(int i=0;i<n;i++){
        if(t[i]!=i){
            while(t[0]!=0){
                swap(t[0],t[t[0]]);
                cnt++;
            }
            if(t[i]!=i){
                swap(t[0],t[i]);
                cnt++;
            }
        }
    }
    cout<<cnt;
    return 0;
}