1. 程式人生 > >PAT甲級 1121 Damn Single (25 分)set

PAT甲級 1121 Damn Single (25 分)set

1121 Damn Single (25 分)

"Damn Single (單身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

解析:該題的關鍵點在於一個夫婦中只出現一人和兩人都出現如何區分。這裡用isExist去判斷。例如夫婦中的男方出現,不知道男方是否能輸出,但女方一定要標記為不能輸出。這樣處理即可輕鬆AC。

#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
using namespace std;

int main(){
	int n,m,a,b;
	cin>>n;
	vector<int> couple( 100001,-1);
	for(int i=1;i<=n;i++){
		cin>>a>>b;
		couple[a] = b;
		couple[b] = a;
	}
	cin>>m;
	vector<int> vec(m),isExist(100001,0);
	for(int i=0;i<m;i++){
		cin>>vec[i];
		if(couple[vec[i]] != -1){
			//夫婦中的男方出現,不知道男方是否能輸出,但女方一定不能輸出 
			isExist[couple[vec[i]]] = 1;
		}			
	}
	set<int> s;
	for(int i=0;i<m;i++)
		if(isExist[vec[i]] == 0)
			s.insert(vec[i]);
	
	int cnt = s.size(),i = 0;
	cout<<cnt<<endl;
	for(auto it = s.begin();it!=s.end();it++)
		printf("%s%05d",it!=s.begin()?" ":"",*it);
	//for(auto it:s){
	//	printf("%05d%s",it,i!=cnt - 1?" ":"");
	//	i++;
	//}
		
	return 0;
}