1. 程式人生 > >PAT 甲級1118 Birds in Forest (25 分)並查集

PAT 甲級1118 Birds in Forest (25 分)並查集

1118 Birds in Forest (25 分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes

 if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

解析: 該題就是一個並查集的簡單應用。題目要求輸出集合的數量, 出現點的個數。接著判斷出兩個點是否是在一個集合即可。

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

int pre[10001],flag[10001],t[10001];

int find(int x){
	int a = x;
	while(pre[a]!=a)
		a = pre[a];
	int i = x,j;
	while(pre[i]!=a){
		j = pre[i];
		pre[i] = a;
		i = j;
	}
	return a;
}

void unio(int x,int y){
	int fx = find(x),fy = find(y);
	if(fx!=fy){
		pre[fx] = fy;
	}
}

int main(){
	int n,m,a,b;
	cin>>n;
	for(int i=0;i<10001;i++)
		pre[i] = i;

	vector<int> vec;//記錄出現過的點 
	int sum = 0;
	for(int i=0;i<n;i++){
		cin>>m>>a;
		if(flag[a] == 0){
			sum++;
			vec.push_back(a);
			flag[a] = 1;
		}	
		for(int j=0;j<m-1;j++){
			cin>>b;
			if(flag[b] == 0){
				sum++;
				flag[b] = 1;
				vec.push_back(b);
			}		
			unio(a,b);
		}	
	}
	int cnt = 0;//記錄集合的數量 
	for(int i=0;i<vec.size();i++){
		if(t[find(vec[i])] == 0){//找到所有的根 
			t[find(vec[i])] = 1;
			cnt++;
		}		
	}
	cin>>m;
	cout<<cnt<<" "<<sum<<endl;
	for(int i=0;i<m;i++){
		cin>>a>>b;
		if(find(a) == find(b))
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;	
	}
	
	return 0;
}