1. 程式人生 > >線段樹—Just a Hook(區間更新,區間求和)

線段樹—Just a Hook(區間更新,區間求和)

Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input 1 10 2 1 5 2 5 9 3 Sample Output Case 1: The total value of the hook is 24. 題意: 給你n個元素,初始化都是1;輸入a,b,c ,將[a,b]區間裡的元素的值改為c(這裡c={1,2,3}) 經過幾次改變,最後求這n個元素的和。  一個區間的更新帶來兩個變化,一個是該區間內的小區間的變化,我們用pushdown()操作的;一個是包含該區間的大區間的變化,我們用的pushup()操作的。 這個題也是關於線段樹很基礎的操作。。。但是初次實現程式碼還是出現很多錯。。需要更多的練習。
#if 0
#include<iostream>
using namespace std;
const int MAXX=1e5;
int sum[MAXX*4];
int setv[MAXX*4];
#define lson l,m,id*2
#define rson m+1,r,id*2+1
void pushup(int id)
{
	sum[id]=sum[id*2]+sum[id*2+1];	
} 
void pushdown(int id,int num)
{
	if(setv[id])
	{
		setv[id*2+1]=setv[id*2]=setv[id];
		sum[id*2]=(num-num/2)*setv[id];
		sum[id*2+1]=num/2*setv[id];
		setv[id]=0;	
	}		
} 
void build(int l,int r,int id)
{
	setv[id]=0;
	sum[id]=1;
	if(l==r)
		return;
	int m=(l+r)/2;
	build(lson);
	build(rson);
	pushup(id);	
}
void update(int ql,int qr,int val,int l,int r,int id)
{
	if(ql<=l&&qr>=r)
	{
		setv[id]=val;
		sum[id]=(r-l+1)*val;
		return;	
	}	
	pushdown(id,r-l+1);
	int m=(l+r)/2;
	if(ql<=m) 
		update(ql,qr,val,lson); /////
	if(qr>m)
		update(ql,qr,val,rson);	
	pushup(id);
} 
int query(int ql,int qr,int l,int r,int id)
{
	if(ql<=l&&qr>=r)
	{
		return sum[id];
	}
	pushdown(id,r-l+1);            ///
	int m=(l+r)/2;
	int ret=0;
	if(ql<=m)   
	{
		ret+=query(ql,qr,lson);
	}
	if(qr>m)
	{
		ret+=query(ql,qr,rson);
	}
	return ret;		
} 

int main()
{
	while(1)
	{
		int a,b,n,val;
		cin>>n;	
		build(1,n,1);
		char s;
		while(1)
		{
			cin>>s;
			if(s=='k')
				break;
			if(s=='q')
			{
				cin>>a>>b;
				cout<<query(a,b,1,n,1)<<endl;
			}
			else
			{
				cin>>a>>b>>val;
				update(a,b,val,1,n,1);
			}
		}	
	}	
}
#endif