1. 程式人生 > >1029 Median (25 分)【邊輸入邊輸出】

1029 Median (25 分)【邊輸入邊輸出】

1029 Median (25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int

.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

題意:就是2個有序的連結串列,找出2個連結串列合在一起的中位數

柳婼學姐的程式碼:https://www.liuchuo.net/archives/2248 

#include<bits/stdc++.h>
using namespace std;
int v[200010];
int main(void)
{
	int n,m;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&v[i]);
	}
	v[n+1]=0x7fffffff;
	scanf("%d",&m);//這句和下一句之前調換了位置就錯了
	int j=1,median=(n+m+1)/2,ans=0;
	int temp;
	
	for(int i=1;i<=m;i++)
	{
		scanf("%d",&temp);
		while(v[j]<temp)
		{
			ans++;
			if(ans==median) printf("%d",v[j]);	
			j++;
		}
		ans++;
		if(ans==median) printf("%d",temp);
	}
	while(j<=n)
	{
		ans++;
		if(ans==median) printf("%d",v[j]);
		j++;
	}
	return 0;
}