1. 程式人生 > >1027 Colors in Mars (20 分)【10進位制轉換為13進位制】

1027 Colors in Mars (20 分)【10進位制轉換為13進位制】

1027 Colors in Mars (20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0

 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

題意:給出三個10進位制的數字,將其轉換為13進位制的資料

解題思路:168對13進位制來說最多2位,直接定義一個r[]="0123456789ABC",第一位就是取下標為數字除以13的字元,第二個字元就是取下標為數字取餘13的 字元

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
	char r[]="0123456789ABC";
	int a,b,c;
	scanf("%d %d %d",&a,&b,&c);
	printf("#");
	printf("%c%c%c%c%c%c",r[a/13],r[a%13],r[b/13],r[b%13],r[c/13],r[c%13]);
	return 0;
}