1. 程式人生 > >POJ 1050 To the Max【DP】

POJ 1050 To the Max【DP】

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 48554 Accepted: 25678

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source


做這題前,先弄清楚HDU1003這題。

然後再把二維壓縮為一維就可以了。

1,12,123,1234,2,23,234,3,34,4

按上面幾種情況壓縮,求出最大的即可。

AC程式碼:

/**
  * 行有餘力,則來刷題!
  * 部落格連結:http://blog.csdn.net/hurmishine
  *
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=100+5;
int a[maxn][maxn];
int dp[maxn];
int n;
int getMax(int *a)
{
    int maxx=a[0];
    int sum=a[0];
    for(int i=1;i<n;i++)
    {
        if(sum+a[i]>a[i])
            sum+=a[i];
        else
            sum=a[i];
        if(sum>maxx)
            maxx=sum;
    }
    return maxx;
}
int main()
{
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
                cin>>a[i][j];
        }
        int p;
        int maxx=0;
        for(int i=0;i<n;i++)
        {
            memset(dp,0,sizeof(dp));
            for(int j=i;j<n;j++)
            {
                p=0;
                for(int k=0;k<n;k++)
                {
                    dp[p]+=a[j][k];
                    p++;
                }
                int ans=getMax(dp);
                if(ans>maxx)
                    maxx=ans;
            }
        }
        cout<<maxx<<endl;
    }
    return 0;
}