1. 程式人生 > >poj 1789 Truck History (最小生成樹)

poj 1789 Truck History (最小生成樹)

=Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

<span style="color:#000000">4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0
</span>

Sample Output

The highest possible quality is 1/3.

n個車牌號,剛開始只有一個車牌,其他車牌都是由一個車牌直接或間接產生,一個車牌到另一個車牌的產生權值是它們之間的數字不同的個數,問產生的最小的邊權和
最小生成樹題。

求出所有車牌號生成其他車牌號的值,最小生成樹求。

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<set>
#include<vector>
#include<string>
#include<queue>
using namespace std;
const int maxn =2005;
const int inf = 0x3f3f3f3f;
typedef long long ll;
char str[maxn][8];
int mp[maxn][maxn];
int n;
struct node
{
	int u, v, w;
}edge[maxn*maxn];
int f[maxn];
int k, sum;
int find(int x)
{
	if (x == f[x])
	{
		return x;
	}
	else
	{
		return f[x] = find(f[x]);
	}
}
int we(int i, int j)
{
	int w = 0;
	for (int k = 0; k < 7; k++)
	{
		if (str[i][k] != str[j][k])
		{
			w++;
		}
	}
	return w;
}
bool cmp(node &a, node &b)
{
	return a.w < b.w;
}
int kru()
{
	for (int i = 0; i < k; i++)
	{
		int x = find(edge[i].u);
		int y = find(edge[i].v);
		if (x != y)
		{
			sum += edge[i].w;
			f[x] = y;
		}
	}
	return sum;
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	while (scanf("%d", &n) != EOF)
	{
		if (n == 0)
		{
			break;
		}
		k = sum = 0;
		memset(mp, 0, sizeof(mp));
		for (int i = 1; i <= n; i++)
		{
			cin >> str[i];
			f[i] = i;
		}
		for (int i = 1; i <= n; i++)
		{
			for (int j = i + 1; j <= n; j++)
			{
				mp[i][j] = mp[j][i] = we(i, j);
			}
		}
		for (int i = 1; i <= n; i++)
		{
			for (int j = i + 1; j <= n; j++)
			{
				edge[k].u = i;
				edge[k].v = j;
				edge[k++].w = mp[i][j];
			}
		}
		sort(edge, edge + k, cmp);
		cout << "The highest possible quality is 1/" << kru() << '.' << endl;
	}
	return 0;
}