1. 程式人生 > >hdu 2838 Cow Sorting (樹狀陣列+逆序對變形)

hdu 2838 Cow Sorting (樹狀陣列+逆序對變形)

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=2838

Problem Description

Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.

 

 

Input

Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.

 

 

Output

Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.

 

 

Sample Input

 

3 2 3 1

 

 

Sample Output

 
7

Hint

Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

 

題意:給定一個序列,相鄰的數可相互交換,但以兩數的和作為代價。計算使此序列為升序時,最小的代價。

分析:當前位置的x的代價為前面比其的數的和再加上次數向前移動t次乘x即為最下的代價。在上面一題求交換次數的基礎上面,定義一個結構體增加一個變數求出前面比當前位置大的數的和即可。(也可以通過兩個陣列實現)

程式碼:

#include<cstdio>
#include<cstring>
using namespace std;
#define LL long long
const int N=100008;
struct node
{
    LL num;
    LL val;
}c[N];

void add(LL x,LL y,LL num)
{
    for(;x<=N;x+=(x&(-x)))
    {
        c[x].val+=y;
        c[x].num+=num;
    }
}
LL num_sum(LL  x)
{
    LL  ans=0;
    for(;x;x-=(x&(-x)))
    {
        ans+=c[x].num;
    }
    return ans;
}
LL val_sum(LL  x)
{
     LL  ans=0;
    for(;x;x-=(x&(-x)))
    {
        ans+=c[x].val;
    }
    return ans;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
      LL ans=0;
      memset(c,0,sizeof(c));
      for(int i=1;i<=n;i++)
      {
        LL  x;
        scanf("%lld",&x);
        add(x,x,1);
        int time=i-num_sum(x);
        ans+=(LL)(time*x+val_sum(n)-val_sum(x));
      }
      printf("%lld\n",ans);
    }
    return 0;
}