1. 程式人生 > >poj 2388 Quick_sort 求中間值

poj 2388 Quick_sort 求中間值

Who's in the Middle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 42058 Accepted: 24335

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3
//下面是程式碼,題意就是排好序後求中間的那個數
#include<stdio.h>
#define MAX 10005
int a[MAX];
void quick_sort(int s[], int l, int r)
{
	if (l < r)
	{
		int i = l, j = r, x = s[l];
		while (i < j)
		{
			while(i < j && s[j] >= x) // 從右向左找第一個小於x的數
				j--;  
			if(i < j) 
				s[i++] = s[j];

			while(i < j && s[i] < x) // 從左向右找第一個大於等於x的數
				i++;  
			if(i < j) 
				s[j--] = s[i];
		}
		s[i] = x;
		quick_sort(s, l, i - 1); // 遞迴呼叫 
		quick_sort(s, i + 1, r);
	}
}
int main()
{
int T;
scanf("%d",&T);
for(int i=0;i<T;i++)
{
scanf("%d",&a[i]); 
}
quick_sort(a,0,T-1); 
printf("%d\n",a[T/2]);
	return 0;
}