1. 程式人生 > >【POJ】1502MPI Maelstrom(dijkstra,輸入)

【POJ】1502MPI Maelstrom(dijkstra,輸入)

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12770   Accepted: 7868

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

Source

East Central North America 1996

題目大意:是給出你一個類似於下三角的鄰接矩陣,但是上面的沒給出,因為是無向圖,所以矩陣是對稱的,而且自己到自己預設是0,所以這個矩陣上也沒有給出,這個題還是直接看Input 那一塊比較好吧,其他感覺沒啥用。。。。

思路:整理好輸入吧,基本上dijkstra的模板題目了,我看網上還有大神是用的atio做的,我這裡是參考的另一位大神的輸入方式,用的sscanf的方法,可以上網查一下,

程式碼:

#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<cstring>
#include<algorithm>
#define inf 0x3f3f3f3f3f
#define maxn 1005
using namespace std;
int n;
struct HeapNode
{
    int d,u;
    HeapNode(int d,int u):d(d),u(u){}
    bool operator < (const HeapNode & ags) const
    {
        return d>ags.d;
    }
};
struct Edge
{
    int from,to,dist;
    Edge(int f,int t,int d):from(f),to(t),dist(d){}
};

struct Dijkstra
{
    int n,m;
    vector<int > G[maxn];
    vector<Edge> edges;
    bool done[maxn];
    int d[maxn];
    int p[maxn];

    void init(int n)
    {
        this->n=n;
        for(int i=0;i<n;i++) G[i].clear();

        edges.clear();
    }

    void AddEdges(int from,int to,int dist)
    {
        edges.push_back(Edge(from,to,dist));
        m=edges.size();
        G[from].push_back(m-1);
    }

    void dijkstra(int s)
    {
        priority_queue<HeapNode>Q;
        for(int i=0;i<n;i++) d[i]=inf;
        d[s]=0;

        memset(done,0,sizeof(done));
        Q.push(HeapNode(0,s));

        while(!Q.empty())
        {
            HeapNode x=Q.top();Q.pop();
            int u=x.u;
            if(done[u])
                continue;
            done[u]=true;

            for(int i=0;i<G[u].size();i++)
            {
                Edge &e=edges[G[u][i]];

                if(d[e.to]>d[u]+e.dist)
                {
                    d[e.to]=d[u]+e.dist;
                    p[e.to]=G[u][i];
                    Q.push(HeapNode(d[e.to],e.to));
                }
            }
        }
    }
}DJ;

int main()
{
    while(scanf("%d",&n)==1)
    {
        DJ.init(n);
        for(int i=1;i<n;i++)
        for(int j=0;j<i;j++)
        {
            char str[10];
            int d;
            scanf("%s",str);
            if(str[0]!='x')
            {
                sscanf(str,"%d",&d);
                DJ.AddEdges(i,j,d);
                DJ.AddEdges(j,i,d);
            }
        }
        DJ.dijkstra(0);
        int max_v=-1;
        for(int i=0;i<n;i++)
            max_v = max(max_v,DJ.d[i]);
        printf("%d\n",max_v);
    }
    return 0;
}