1. 程式人生 > >POJ 3254 Corn Fields(狀壓DP)

POJ 3254 Corn Fields(狀壓DP)

題目連結

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:

1 2 3
  4  


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
const int maxn=1e4+10;
const int mod=100000000;
const int inf=1e8;
#define me(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&(-x)
typedef long long ll;
using namespace std;
int dp[20][1<<12],state[maxn],fit[15],tot;
int n,m;
bool check(int x)
{
    if(x&(x<<1))// x左移1後每個位置都和原先後邊的位置進行&運算, 若有相鄰的1, 則會得到1;
        return 0;
    return 1;
}
bool check1(int x,int i)
{
    if(x&fit[i])//fild存的是土地狀態取反;若x&fild[i]==1表示在兩數的某位置都為1;
        return 0;
    return 1;
}
void init()//提前存下可行狀態
{
    tot=0;
    for(int i=0; i<(1<<n); i++)
        if(check(i))
            state[++tot]=i;
}
int main()
{
    scanf("%d%d",&m,&n);
    init();
    for(int i=1; i<=m; i++)
    {
        fit[i]=0;
        for(int j=1; j<=n; j++)
        {
            int x;scanf("%d",&x);
            if(x==0)
                fit[i]+=(1<<(n-j));//反著存,0表示可以放,1表示不能放
        }
    }
    for(int i=1; i<=tot; i++)//判斷第一行;找出第一行可行方案;
        if(check1(state[i],1))
            dp[1][i]=1;
    for(int i=2;i<=m;i++)
    {
        for(int j=1;j<=tot;j++)
        {
            if(!check1(state[j],i))//該位置與當前列衝突。
                continue ;
            for(int k=1;k<=tot;k++)
            {
                if(!check1(state[k],i-1))//當前行與上一行衝突
                    continue ;
                if(state[j]&state[k])//同一行兩個位置衝突。
                    continue ;
                dp[i][j]=(dp[i][j]+dp[i-1][k])%mod;
            }
        }
    }
    int ans=0;
    for(int i=1;i<=tot;i++)
        ans=(ans+dp[m][i])%mod;
    cout<<ans<<endl;
    return 0;
}