問題點描述:

device eth0 does not seem to present delaying initialization

解決方法:

在VMware裡克隆出來的CentOS Linux。。

ifconfig...沒有看到eth0.。然後重啟網絡卡又報下面錯誤。

故障現象:

service network restart
Shutting down loopback insterface:                                                                                                     [  OK  ]
Bringing up loopback insterface:                                                                                                          [  OK  ]
Bringing up interface eth0:  Device eth0 does not seem to be present,delaying initialization.                    [FAILED]

CentOS Linux解決Device eth0 does not seem to be present

解決辦法:

首先,開啟/etc/udev/rules.d/70-persistent-net.rules內容如下面例子所示:

# vi /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.
# PCI device 0x1022:0x2000 (pcnet32)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0c:29:8f:89:9
7", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x1022:0x2000 (pcnet32)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0c:29:50:bd:1
7", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

記錄下,eth1網絡卡的mac地址00:0c:29:50:bd:17

接下來,開啟/etc/sysconfig/network-scripts/ifcfg-eth0

# vi /etc/sysconfig/network-scripts/ifcfg-eth0

將 DEVICE="eth0"  改成  DEVICE="eth1"  ,
將 HWADDR="00:0c:29:8f:89:97" 改成上面的mac地址  HWADDR="00:0c:29:50:bd:17"

最後,重啟網路

# service network restart
或者

# /etc/init.d/network restart

正常了。

原因可能是因為我本地有兩個node11的虛擬機器,導致這個上邊的資訊連結到了另一臺虛擬機器上了。