1. 程式人生 > >(PAT)1055 The World's Richest(難題,比較難的排序)

(PAT)1055 The World's Richest(難題,比較難的排序)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin

Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin

Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

解題思路:

一開始我嘗試建立多個數組來儲存不同年齡段的人,不過查詢量比較大,兩個測試用例超時了。

注意到M的範圍在100以內,因此可以進行預處理,即將每個年齡中財富在前100的人篩選出放在陣列中即可

(即在原來排過序的陣列中刪去100名以外的)

這樣最多最多有10000個人在陣列中,查詢時,挨個遍歷即可

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <algorithm>
#include <string.h>
#include <vector>
#include <string>
using namespace std;
struct Person
{
	int age, wealth;
	char name[20];
}Persons[10010],validPersons[10010];
bool cmp(Person a, Person b) {
	if (a.wealth!= b.wealth) {
		return a.wealth > b.wealth;
	}
	else {
		if (a.age != b.age) {
			return a.age < b.age;
		}
		else {
			return strcmp(a.name, b.name) < 0;
		}
	}
}
int Ages[10010] = { 0 };  //年齡無法超過100
int main() {
	int N, M;
	scanf("%d %d", &N, &M);
	for (int i = 0; i < N; ++i) {
		scanf("%s %d %d", &Persons[i].name, &Persons[i].age, &Persons[i].wealth);
	}
	sort(Persons, Persons + N, cmp);
	int validNumber = 0;
	for (int i = 0; i < N; ++i) {
		if (Ages[Persons[i].age] < 100) {   //各年齡段只要篩選前100名就行了 這樣100*100最多不會超過10000
			Ages[Persons[i].age]++;
			validPersons[validNumber++] = Persons[i];
		}
	}
	for (int i = 0; i < M; ++i) {
		int ranks, low, high;
		scanf("%d %d %d", &ranks, &low, &high);
		int printNumber = 0;
		printf("Case #%d:\n", i + 1);
		for (int j = 0; j < validNumber && printNumber < ranks; j++) {   //不能超過陣列中總人數,也不能超過需要列印的人數
			if (validPersons[j].age <= high && validPersons[j].age >= low) {
				printf("%s %d %d\n", validPersons[j].name, validPersons[j].age, validPersons[j].wealth);
				printNumber++;
			}
		}
		if (printNumber == 0) {
			printf("None\n");
		}
	}
	system("PAUSE");
	return 0;
}