1. 程式人生 > >A1035 Password (20 分)

A1035 Password (20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1

 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified

 where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 [email protected]

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

題意:

 給定N個使用者的姓名(Name)和密碼,現需要吧把密碼中的‘1’ 給為 ‘@’, ‘0’ 改為 ‘%’, ‘l’ 改為 ‘L’, 'O' 改為 'o', 若沒有修改的密碼,按照單複數輸出There is(are) 1(N) account(s) and no account is modified.其中N (≤1000), 字元數不超過10個。

注意:

  1. 建立結構體儲存姓名和密碼,同時將該使用者是否修改ischange存於結構體中。
  2. 函式 crypt 用於實現:判斷輸入的密碼是否需要修改,進行修改,置ischange的值,同時增加計數器cnt的值。
  3. 當cnt==0時,即沒有要修改的數時,注意單複數輸出。
#include <cstdio>
#include <cstring>
struct node{
  char name[20], password[20];
  bool ischange;
}T[1005];

void crypt(node &t, int &cnt){
  int len = strlen(t.password);
  for(int i = 0; i < len; i++){
    if(t.password[i] == '1'){
      t.password[i] = '@';
      t.ischange = true;
    }
    else if(t.password[i] == '0'){
      t.password[i] = '%';
      t.ischange = true;
    }
    else if(t.password[i] == 'l'){
      t.password[i] = 'L';
      t.ischange = true;
    }
    else if(t.password[i] == 'O'){
      t.password[i] = 'o';
      t.ischange = true;
    }
  }
  if(t.ischange)
    cnt++;
}

int main(){
  int n, cnt = 0;
  scanf("%d", &n);
  for(int i = 0; i < n; i++){
    scanf("%s %s", T[i].name, T[i].password);
    T[i].ischange = false;  
  }
  for(int i = 0; i < n; i++)
    crypt(T[i], cnt);
  if(cnt == 0){
    if(n == 1)
      printf("There is 1 account and no account is modified");
    else
      printf("There are %d accounts and no account is modified", n);
  }
  else{
    printf("%d\n", cnt);
    for(int i = 0; i < n; i++){
      if(T[i].ischange)
        printf("%s %s\n", T[i].name, T[i].password);
    }
  }
  return 0;
}