1. 程式人生 > >Max Sum Plus Plus(動態規劃難題:m段子段和的最大值)

Max Sum Plus Plus(動態規劃難題:m段子段和的最大值)

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38381    Accepted Submission(s): 13747


 

Problem Description

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1

, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix
 ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2

, S3 ... Sn.
Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3 2 6 -1 4 -2 3 -2 3

Sample Output

6 8

Hint

Huge input, scanf and dynamic programming is recommended.

Author

JGShining(極光炫影)

AC code:

#include<bits/stdc++.h>

using namespace std;

const int maxn = 1e6+5;

int a[maxn];
//int dp[maxn][maxn];
int d[maxn];
int pre[maxn];

int main()
{
//	freopen("D:\\in.txt","r",stdin);
	int m,n,i,j,k;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
//		memset(dp,0,sizeof(dp));
//		for(i=1;i<=n;i++)
//		{
//			for(j=1;j<=m;j++)
//			{
//				dp[i][j]=dp[i-1][j]+a[i];
//				for(k=1;k<i;k++)
//				{
//					dp[i][j]=max(dp[i][j],dp[k][j-1]+a[i]);
//				}
//			}
//		}
		memset(d,0,sizeof(d));
		memset(pre,0,sizeof(pre));
		int nowans=0;
		for(j=1;j<=m;j++)
		{
			nowans = -1e9;
			for(i=j;i<=n;i++)
			{
				d[i]=max(d[i-1],pre[i-1])+a[i];
				pre[i-1]=nowans;
				nowans = max(nowans,d[i]);
			}
		}
		printf("%d\n",nowans);
	}
	return 0;
}