1. 程式人生 > >POJ 2406 Power Strings 求連續重複字串(kmp)

POJ 2406 Power Strings 求連續重複字串(kmp)

Power Strings
Time Limit:3000MS Memory Limit:65536K
Total Submissions:29827 Accepted:12456

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


kmp的next陣列具有此性質:一個串的最小迴圈節長度是len-next[len]。
如果len%(len-next[len])==0,那麼這個字串的最小週期就是:len/(len-next[len]).

//5248K	110MS
#include<stdio.h>
#include<string.h>
#define M 1000007
int next[M];
char pattern[M];
void pre(int len)
{
	int i = 0, j = -1;
	next[0] = -1;
	while(i != len)
	{
		if(j == -1 || pattern[i] == pattern[j])
			next[++i] = ++j;
		else
			j = next[j];
	}
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%s",pattern)!=EOF)
    {
        if(strcmp(pattern,".")==0)break;
        int len=strlen(pattern);
        pre(len);
        if(len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else printf("1\n");
    }
    return 0;
}