1. 程式人生 > >hdu6030(推導+矩陣快速冪)

hdu6030(推導+矩陣快速冪)

Happy Necklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1734    Accepted Submission(s): 730

Problem Description

Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly n beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo 109+7.
Note: The necklace is a single string, {not a circle}

.

Input

The first line of the input contains an integer T(1≤T≤10000), denoting the number of test cases.
For each test case, there is a single line containing an integer n(2≤n≤1018), denoting the number of beads on the necklace.

Output

For each test case, print a single line containing a single integer, denoting the answer modulo 109+7.

Sample Input

2

2

3

Sample Output

3

4

Source

解析:推導公式是最難的了。其他的套模板。

fn=fn-1+fn-3;

構造矩陣

fn        1        0        1         fn-1

fn-1     1        0        0         fn-2

fn-2     0        1        0         fn-3

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

struct mat  
{
    ll a[3][3];
};
mat mat_mul(mat x,mat y)  
{
    mat res;  
    memset(res.a,0,sizeof(res.a));  
    for(int i=0;i<3;i++)  
        for(int j=0;j<3;j++) 
        for(int k=0;k<3;k++)
        res.a[i][j]=(res.a[i][j]+x.a[i][k]*y.a[k][j])%mod;  
    return res;  
}
void mat_pow(ll n)
{
    mat c,res;
    mem(c.a,0);
    c.a[0][0]=c.a[0][2]=c.a[1][0]=c.a[2][1]=1;
    mem(res.a,0); 
    for(int i=0;i<3;i++) res.a[i][i]=1;  
    while(n)
    {
        if(n&1) res=mat_mul(res,c);  
        c=mat_mul(c,c);  
        n=n>>1;
    }
    printf("%lld\n",(res.a[0][0]*3%mod+res.a[0][1]*2%mod+res.a[0][2])%mod);
}
int main()
{
	int T;scanf("%d",&T);
	while(T--)
	{
		ll n;scanf("%lld",&n);
		if(n==1){puts("1");continue;}
		if(n==2){puts("3");continue;}
		if(n==3){puts("4");continue;}
		
		mat_pow(n-2);
	}
	return 0;
}