1. 程式人生 > >【Poj】-A Simple Problem with Integers(線段樹,區間更新)

【Poj】-A Simple Problem with Integers(線段樹,區間更新)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 100877 Accepted: 31450
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa

Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source


區間更新的裸題,理解

#include<cstdio>
#include<cstring>
#include<stack>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define LL long long
#define MAX 100000
#define L o<<1
#define R o<<1|1
struct node
{
	int l,r;
	LL sum,lazy;		//延遲標記
	int length;			//區間長度 
}Tree[MAX<<2];

void PushUp(int o)
{
	Tree[o].sum=Tree[L].sum+Tree[R].sum;
}

void Build(int o,int l,int r)
{
	Tree[o].l=l;
	Tree[o].r=r;
	Tree[o].lazy=0;
	Tree[o].length=r-l+1;
	if(l==r)
	{
		scanf("%lld",&Tree[o].sum);
		return ;
	}
	int mid=(Tree[o].l+Tree[o].r)>>1;
	Build(L,l,mid);
	Build(R,mid+1,r);
	PushUp(o);
}

void PushDown(int o)		//向下傳遞 lazy ,o的lazy=0 
{
	if(Tree[o].lazy)
	{
		Tree[L].sum+=Tree[L].length*Tree[o].lazy;
		Tree[R].sum+=Tree[R].length*Tree[o].lazy;
		Tree[L].lazy+=Tree[o].lazy;
		Tree[R].lazy+=Tree[o].lazy;
		Tree[o].lazy=0;
	}
}

void UpDate(int o,int l,int r,int lazy)		 
{
	if(Tree[o].l==l&&Tree[o].r==r)
	{
		Tree[o].sum+=Tree[o].length*lazy;	//更新當前節點的值,後向下傳遞 lazy 
		Tree[o].lazy+=lazy;
		return ;
	}
	PushDown(o);
	int mid=(Tree[o].l+Tree[o].r)>>1;
	if(r<=mid)
		UpDate(L,l,r,lazy);
	else if(l>mid)
		UpDate(R,l,r,lazy);
	else
	{
		UpDate(L,l,mid,lazy);
		UpDate(R,mid+1,r,lazy);
	}
	PushUp(o);
}

LL Query(int o,int l,int r)
{
	if(Tree[o].l==l&Tree[o].r==r)
		return Tree[o].sum;
	PushDown(o);	
	int mid=(Tree[o].l+Tree[o].r)>>1;
	if(r<=mid)
		return Query(L,l,r);
	else if(l>mid)
		return Query(R,l,r);
	else
		return Query(L,l,mid)+Query(R,mid+1,r);
}

int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	Build(1,1,n);	
	char s[2];
	int a,b,c;
	while(m--)
	{
		scanf("%s",s);
		if(s[0]=='Q')
		{
			scanf("%d%d",&a,&b);
			printf("%lld\n",Query(1,a,b));
		} 
		else	
		{
			scanf("%d%d%d",&a,&b,&c);
			UpDate(1,a,b,c);
		} 
	}
 	return 0;
}