1. 程式人生 > >hdoj1455 poj1011 nyoj293 Sticks【DFS+剪枝】

hdoj1455 poj1011 nyoj293 Sticks【DFS+剪枝】

Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 128649 Accepted: 30149

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
int stick[70];
int vis[70];
int cont,nowcount;
int len;
int num;
bool cmp(int a,int b)
{
	return a>b;
}
bool dfs(int k,int leftlen)
{
	if(leftlen==0)
	{
		nowcount++;
		if(nowcount==cont)return true;
		int i=0;
		while(vis[i])i++;
		vis[i]=1;
		if(dfs(i+1,len-stick[i]))return true; 
		vis[i]=0;nowcount--;
		return false;//若當前最長的木棍不匹配則不能匹配 
	}
	for(int i=k;i<num;++i)
	{
		if(!vis[i]&&stick[i]<=leftlen)
		{
			if(stick[i]==stick[i-1]&&!vis[i-1])continue;//前一個相同長度的沒有匹配則以後相同的必定不會匹配 
			vis[i]=1;
			if(dfs(i+1,leftlen-stick[i]))return true;
			vis[i]=0;if(leftlen-stick[i]==0)return false;//當一根木棍已經匹配但不滿足條件則不能完成匹配 
		}
	}
	return false;
}
int main()
{
	int i,j;
	while(scanf("%d",&num),num)
	{
		int sum=0;
		for(i=0;i<num;++i)
		{
			scanf("%d",&stick[i]);
			sum+=stick[i];vis[i]=0;
		}
		sort(stick,stick+num,cmp);
		int flag=0;vis[0]=1;
		for(len=stick[0];len<=sum/2;++len)//len最大為sum的1/2 
		{
			if(sum%len)continue;//sum必定為len的倍數 
			cont=sum/len;nowcount=0;
			if(dfs(1,len-stick[0]))
			{
				printf("%d\n",len);
				flag=1;break;
			}
		}
		if(flag==0)printf("%d\n",sum);
	}
	return 0;
}