1. 程式人生 > >poj 1417(並查集+簡單dp)

poj 1417(並查集+簡單dp)

True Liars
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2087 Accepted: 640

Description

After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell.

In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie.

He asked some of them whether or not some are divine. They knew one another very much and always responded to him "faithfully" according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia.

You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries.

Input

The input consists of multiple data sets, each in the following format :

n p1 p2
xl yl a1
x2 y2 a2
...
xi yi ai
...
xn yn an

The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since "are you a member of the divine tribe?" is a valid question. Note also that two lines may have the same x's and y's since Akira was very upset and might have asked the same question to the same one more than once.

You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included.

Output

For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e., if a given data set does not include sufficient information to identify all the divine members, print no in a line.

Sample Input

2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0

Sample Output

no
no
1
2
end
3
4
5
6
end
題意:有A和B兩個部落,A部落的人都是好人,始終講實話,而B部落的人都是壞淫,都說謊話,題目給出n,代表問題的個數,給出p1和p2代表兩個部落的人,然後a,b,ch,如果a說b是好人則ch是yes,否則是no,然後根據問題得出的回答能不能確定誰是好人,誰是壞淫,若可以且情況唯一,則按順序輸出好人的編號,否則輸出no
分析:對於a,b,yes,若a是好人,則b一定是好人,若a是壞淫,則b一定是壞人,對於a,b,no,若a是好人,則b是壞人,若a是壞人,則a在說謊,b則是好人,所以yes的時候a和b在同一個集合中,no的時候a和b不在一個集合中,所以,應該用並查集路徑壓縮判斷,得出每個集合的兩類人數,然後利用dp[i][j]記錄到第i個集合的時候有j個好人的情況個數,若為一種情況,則用pre[i][j]記錄路徑
程式:
#include"cstdio"
#include"cstring"
#include"cstdlib"
#include"cmath"
#include"string"
#include"map"
#include"cstring"
#include"iostream"
#include"algorithm"
#include"queue"
#include"stack"
#define inf 0x3f3f3f3f
#define M 1000
#define eps 1e-8
#define INT int
using namespace std;
int f[M],h[M],num[M],sum[M],pre[M][M],s[M];
int dp[M][M];
struct node
{
    int a,b;
}belong[M],mark[M];
int finde(int x)
{
    if(x!=f[x])
    {
        int y=f[x];
        f[x]=finde(f[x]);
        sum[x]=(sum[x]+sum[y])%2;
    }
    return f[x];
}
void make(int a,int b,int k)
{
    int x=finde(a);
    int y=finde(b);
    if(x<y)
    {
        f[y]=x;
        sum[y]=(2+sum[y]+sum[a]+k-sum[b])%2;
        h[x]+=h[y];
    }
    else if(y<x)
    {
        f[x]=y;
        sum[x]=(2+sum[x]+sum[b]+k-sum[a])%2;
        h[y]+=h[x];
    }
}
int main()
{
    int n,p1,p2;
    while(scanf("%d%d%d",&n,&p1,&p2),n||p1||p2)
    {
        memset(belong,0,sizeof(belong));
        memset(mark,0,sizeof(mark));
        for(int i=1;i<=p1+p2;i++)
        {
            f[i]=i;
            h[i]=1;
            sum[i]=0;
        }
        for(int i=1;i<=n;i++)
        {
            int a,b;
            char ch[6];
            scanf("%d%d%s",&a,&b,ch);
            if(strcmp(ch,"yes")==0)
                make(a,b,0);
            else
                make(a,b,1);
        }
        int cnt=0;
        for(int i=1;i<=p1+p2;i++)
        {
            if(f[i]==i)
            {
                num[i]=++cnt;
            }
        }
        for(int i=1;i<=p1+p2;i++)
        {
            f[i]=finde(i);
            if(sum[i]==0)
                belong[num[f[i]]].a++;
            else
                belong[num[f[i]]].b++;
        }
        //for(int i=1;i<=cnt;i++)
            //printf("%d %d\n",belong[i].a,belong[i].b);
        memset(dp,0,sizeof(dp));
        memset(pre,-1,sizeof(pre));
        dp[0][0]=1;
        for(int i=1;i<=cnt;i++)
        {
            for(int j=p1;j>=0;j--)
            {
                if(j-belong[i].a>=0)
                dp[i][j]+=dp[i-1][j-belong[i].a];
                if(j-belong[i].b>=0)
                dp[i][j]+=dp[i-1][j-belong[i].b];

                if(dp[i][j]==1)
                {
                    if(j-belong[i].a>=0&&dp[i-1][j-belong[i].a]==1)
                    {
                        pre[i][j]=1;
                    }
                    if(j-belong[i].b>=0&&dp[i-1][j-belong[i].b]==1)
                    {
                        pre[i][j]=2;
                    }
                }
            }
        }
        if(dp[cnt][p1]!=1)
        {
            printf("no\n");
        }
        else
        {
            int j=p1;
            for(int i=cnt;i>=1;i--)
            {
                if(pre[i][j]==1)
                {
                    //printf("%d\n",belong[i].a);
                    j-=belong[i].a;
                    mark[i].a++;
                }
                else
                {
                    //printf("%d\n",belong[i].b);
                    j-=belong[i].b;
                    mark[i].b++;
                }
            }
            int cot=0;
            for(int i=1;i<=p1+p2;i++)
            {
                if(mark[num[f[i]]].a&&sum[i]==0)
                {
                    s[cot++]=i;
                }
                else if(mark[num[f[i]]].b&&sum[i]==1)
                {
                    s[cot++]=i;
                }
            }
            for(int i=0;i<cot;i++)
                printf("%d\n",s[i]);
            printf("end\n");
        }
    }
    return 0;
}