1. 程式人生 > >PAT甲級--1007 Maximum Subsequence Sum (25)(25 分)【最大子序列和及其起始和終點】

PAT甲級--1007 Maximum Subsequence Sum (25)(25 分)【最大子序列和及其起始和終點】

1007 Maximum Subsequence Sum (25)(25 分)

Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10

-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

題意:就是給你一個序列,找出它的最大子序列和,不過這題特殊的地方是要輸出這個子序列的起始值和終點值,要多增加幾個變數,及時更新就可以了。

//線性,就一直往後加,但是一旦當前加的值小於0,就將當前的值更新成0;切記:不一定是連續的正整數相加是最大的 
#include<bits/stdc++.h>
using namespace std;
int num[10005];
int main(void)
{
	int k,start,end;
	scanf("%d",&k);
	int count=0;
	for(int i=0;i<k;i++) 
	{
		scanf("%d",&num[i]);
		if(num[i]<0) count++;
	}
	if(count==k)
	{
		printf("0 %d %d\n",num[0],num[k-1]);
		return 0;
	}
	int cumax=num[0],max=num[0],temp;
	start=0,end=0;
	for(int i=1;i<k;i++)
	{
		if(cumax<0) //我在交的時候這裡不小心寫成了max,造成了段錯誤 
		{
			temp=i;
			cumax=0;
		}
		cumax+=num[i]; //就一直加,一旦小於0,更新為0,一旦大於最大值,更新最大值
		if(cumax>max) //更新
		{
			start=temp;//更新起始值
			end=i;//更新終點值
			max=cumax;//更新最大值
		}
	}
	printf("%d %d %d\n",max,num[start],num[end]);
	return 0;
}