1. 程式人生 > >HDU 1698 Just a Hook (線段樹區間更新)

HDU 1698 Just a Hook (線段樹區間更新)

Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input 1 10 2 1 5 2 5 9 3
Sample Output Case 1: The total value of the hook is 24.

題目意思:就是給一個n個位置(1~n),剛開始每一個位置價值賦值為1,後來跟新一段的值  例如  1   5   2  表示把1~5的位置全部變成價值為2,最後輸出1~n所有位置價值和

不好理解的地方是pushdown()函式,例如輸入1,n 2,我標記1到n是一樣的價值(f[pos].va=1),又輸入1 3 1時,我需要吧

前面的2傳遞給4到n,再更新1~3

不懂就好好理解吧,都是那麼苦逼過來的

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;
#define N 100005

int a[N];

struct stud{
int le,ri;
int cover;
int va;
}f[N*4];


void pushdown(int pos)
{
    if(f[pos].cover)
    {
        f[L(pos)].va=f[R(pos)].va=f[pos].va;
        f[L(pos)].cover=f[R(pos)].cover=1;
        f[pos].cover=0;
    }
}
void build(int pos,int le,int ri)
{
    f[pos].le=le;
    f[pos].ri=ri;

    f[pos].va=1;
    f[pos].cover=1;
    if(le==ri)  return ;

    int mid=MID(le,ri);

    build(L(pos),le,mid);
    build(R(pos),mid+1,ri);
}

void update(int pos,int le,int ri,int va)
{
    if(f[pos].le==le&&f[pos].ri==ri)
    {
        f[pos].va=va;
        f[pos].cover=1;
        return ;
    }

    pushdown(pos);

    int mid=MID(f[pos].le,f[pos].ri);
    if(mid>=ri)
        update(L(pos),le,ri,va);
    else
        if(mid<le)
          update(R(pos),le,ri,va);
    else
    {
        update(L(pos),le,mid,va);
        update(R(pos),mid+1,ri,va);
    }
}

int query(int pos)
{
    if(f[pos].cover)
        return f[pos].va*(f[pos].ri-f[pos].le+1);

    pushdown(pos);

    return query(L(pos))+query(R(pos));
}


int main()
{
    int n,m,i,t,ca=0;
    scanf("%d",&t);

    while(t--)
    {
        scanf("%d",&n);

        build(1,1,n);

        scanf("%d",&m);

        int le,ri,va;

        while(m--)
        {
            scanf("%d%d%d",&le,&ri,&va);
            update(1,le,ri,va);
        }

        printf("Case %d: The total value of the hook is %d.\n",++ca,query(1));
    }
    return 0;
}