1. 程式人生 > >ACM-BFS之勝利大逃亡——hdu1253

ACM-BFS之勝利大逃亡——hdu1253

勝利大逃亡
題目:http://acm.hdu.edu.cn/showproblem.php?pid=1253
Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,這可是Ignatius逃亡的好機會.

魔王住在一個城堡裡,城堡是一個A*B*C的立方體,可以被表示成A個B*C的矩陣,剛開始Ignatius被關在(0,0,0)的位置,離開城堡的門在(A-1,B-1,C-1)的位置,現在知道魔王將在T分鐘後回到城堡,Ignatius每分鐘能從一個座標走到相鄰的六個座標中的其中一個.現在給你城堡的地圖,請你計算出Ignatius能否在魔王回來前離開城堡(只要走到出口就算離開城堡,如果走到出口的時候魔王剛好回來也算逃亡成功),如果可以請輸出需要多少分鐘才能離開,如果不能則輸出-1.


Input
輸入資料的第一行是一個正整數K,表明測試資料的數量.每組測試資料的第一行是四個正整數A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它們分別代表城堡的大小和魔王回來的時間.然後是A塊輸入資料(先是第0塊,然後是第1塊,第2塊......),每塊輸入資料有B行,每行有C個正整數,代表迷宮的佈局,其中0代表路,1代表牆.(如果對輸入描述不清楚,可以參考Sample Input中的迷宮描述,它表示的就是上圖中的迷宮)

特別注意:本題的測試資料非常大,請使用scanf輸入,我不能保證使用cin能不超時.在本OJ上請使用Visual C++提交.

Output
對於每組測試資料,如果Ignatius能夠在魔王回來前離開城堡,那麼請輸出他最少需要多少分鐘,否則輸出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11

很水很水的廣搜題目,就是將二維廣搜變成三維的就行了,六個方向,前後左右上下。。。

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int a,b,c,t;
struct Coor
{
    int x,y,z,step;
};
int mapp[51][51][51],dis[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
bool vis[51][51][51];

bool judge(int x,int y,int z)
{
    if(x<0 || y<0 || z<0 || x>=a || y>=b || z>=c)   return 0;
    if(vis[x][y][z] || mapp[x][y][z])   return 0;
    return 1;
}

int bfs(int x,int y,int z)
{
    queue <Coor> q;
    Coor pre,next;
    int i;

    pre.x=x;
    pre.y=y;
    pre.z=z;
    pre.step=0;
    vis[x][y][z]=1;
    q.push(pre);

    while(!q.empty())
    {
        pre=q.front();
        q.pop();
        if(pre.x==a-1 && pre.y==b-1 && pre.z==c-1)  return pre.step;
        if(pre.step>t)    return -1;
        for(i=0;i<6;++i)
        {
            next.x=pre.x+dis[i][0];
            next.y=pre.y+dis[i][1];
            next.z=pre.z+dis[i][2];
            if(judge(next.x,next.y,next.z))
            {
                next.step=pre.step+1;
                vis[next.x][next.y][next.z]=1;

                q.push(next);
            }
        }
    }
    return -1;
}

int main()
{
    int i,j,k,sl;
    scanf("%d",&sl);
    while(sl--)
    {
        scanf("%d%d%d%d",&a,&b,&c,&t);
        for(i=0;i<a;++i)
            for(j=0;j<b;++j)
                for(k=0;k<c;++k)
                    scanf("%d",&mapp[i][j][k]);

        memset(vis,0,sizeof(vis));
        printf("%d\n",bfs(0,0,0));
    }
    return 0;
}