1. 程式人生 > >Poj 1325 Machine Schedule【二分匹配-------最小點覆蓋】

Poj 1325 Machine Schedule【二分匹配-------最小點覆蓋】

Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14439 Accepted: 6156

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source


題目大意:

A機器有n個模式,B機器有m個模式,一共有k個任務,初始的時候A、B機器都是模式0,一個任務可以在機器A的ai模式下完成,也可以在機器B的bi模式下完成,每一次機器想要更換模式都需要重新啟動,問完成所有任務最少重新啟動多少次?

思路:

1、經典的二分圖模型。將A機器的模式看成左集合,將B機器的模式看成右集合,對應一個任務,要麼選擇ai,要麼選擇bi來完成,那麼ai和bi之間連一條邊,表示這兩個模式需要二選一,那麼求得的最大匹配==最小點覆蓋。

2、ans==最小點覆蓋。另外注意,如果當輸入的某個任務有模式0的時候,我們可以不用考慮它,因為機器初始的模式就是0.

Ac程式碼:

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
vector<int >mp[10004];
int vis[10004];
int match[10004];
int n,m,k;
int find(int u)
{
    for(int i=0;i<mp[u].size();i++)
    {
        int v=mp[u][i];
        if(vis[v]==0)
        {
            vis[v]=1;
            if(match[v]==-1||find(match[v]))
            {
                match[v]=u;return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        scanf("%d%d",&m,&k);
        memset(match,-1,sizeof(match));
        for(int i=1;i<=n;i++)mp[i].clear();
        for(int i=0;i<k;i++)
        {
            int a,x,y;
            scanf("%d%d%d",&a,&x,&y);
            if(x==0||y==0)continue;
            mp[x].push_back(y);
        }
        int output=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i)==1)
            {
                output++;
            }
        }
        printf("%d\n",output);
    }
}