1. 程式人生 > >hdu 2017 字串統計【JAVA】

hdu 2017 字串統計【JAVA】

字串統計

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 97377    Accepted Submission(s): 53487


Problem Description 對於給定的一個字串,統計其中數字字元出現的次數。
Input 輸入資料有多行,第一行是一個整數n,表示測試例項的個數,後面跟著n行,每行包括一個由字母和數字組成的字串。
Output 對於每個測試例項,輸出該串中數值的個數,每個輸出佔一行。
Sample Input2 asdfasdf123123asdfasdf asdf111111111asdfasdfasdf
Sample Output6 9

水題,一步一個腳印。。

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc = new Scanner(System.in);
        int num = sc.nextInt();
        sc.nextLine();
        while(num-- > 0)
        {
            int count = 0;
            String line = sc.nextLine();
            for(int i = 0;i < line.length();i++)
            {
                char ch = line.charAt(i);
                if(ch >= '0' && ch <= '9')
                {
                    count++;
                }
            }
            System.out.println(count);
        }
    }

}