1. 程式人生 > >POJ2352_Stars_線段樹求字首和

POJ2352_Stars_線段樹求字首和

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 46095 Accepted: 19896

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

大致題意:

在一個二維座標紙上有很多星星,每個星星的等級等於橫座標和縱座標都不超過它的星星數。求處於不同等級的星星數。特別的,輸入星星的座標時,星星已經按縱座標由小到大排好了。

大體思路:

由於縱座標已經排好了,這裡只需要找已有的橫座標不大於這個星星的點的數目。因此可以運用線段樹求(1,n)上的星星的和就是這個星星的等級。

#include<cstdio>
#include<iostream>
#define _max 32010

using namespace std;

int Seg [4*_max] ;
int Lev [15010] ;
int N ;

int query ( int p , int l , int r , int x , int y )
{
	if ( l>=x && r<=y ) return Seg[p] ;
	int mid = ( l + r ) >> 1, ans = 0;
	if ( x<=mid ) ans += query ( 2*p , l , mid , x , y ) ;
	if ( y>mid ) ans+= query ( 2*p+1 , mid+1 , r , x , y ) ;
	return ans;
}

void add ( int p , int l , int r , int x )
{
	if ( l==r ){
		Seg[p] ++ ;
		return ;
	}
	int mid = ( l + r ) >> 1 ;
	if ( x<=mid ) add ( 2*p , l , mid , x ) ;
	else add ( 2*p+1 , mid+1 , r , x ) ;
	Seg[p] = Seg[2*p] + Seg[2*p+1] ;
}

int main ()
{
	//freopen ( "in.txt" , "r" , stdin ) ;

	scanf ( "%d" , &N ) ;

	int x , y ;
	for ( int i=0 ; i<N ; i++ ){

		scanf( "%d %d" , &x , &y ) ;
		x++;
		Lev[query(1,1,_max,1,x)] ++ ;
		add ( 1 , 1 , _max , x ) ;

	}

	for ( int i=0 ; i<N ; i++ )
		printf ( "%d\n" , Lev[i] ) ;

	return 0 ;

}