1. 程式人生 > >ZOJ 1005:Jugs(思維)

ZOJ 1005:Jugs(思維)

Jugs

Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge

In the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.

You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.

A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are

fill A 
fill B 
empty A 
empty B 
pour A B 
pour B A 
success

where "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished.

You may assume that the input you are given does have a solution.

Input

Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca <= Cb and N <= Cb <=1000 and that A and B are relatively prime to one another.

Output

Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line "success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces.

Sample Input

3 5 4
5 7 3

Sample Output

fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success

題意

有兩個瓶子A,B。A,B瓶子容量已知(B的容量>=A的容量),但是每個瓶子內沒有刻度,問如何操作能夠量取體積為N的水

思路

因為B瓶子的容量>=A瓶子的容量,所以可以利用A,B瓶子容量的差值來進行求解:

1.如果A中沒有水,將A裝滿

2.將A中的水全部倒入B中(此時根據A,B中的總水量來判斷A倒入B後的各個瓶子裡面的水量)

3.判斷B中的水量是否等於N,如果等於N,停止操作,否則,將B中的水全部倒出

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <string>
#define ll long long
#define ull unsigned long long
#define ms(a) memset(a,0,sizeof(a))
#define pi acos(-1.0)
#define INF 0x7f7f7f7f
#define lson o<<1
#define rson o<<1|1
const double E=exp(1);
const int maxn=1e6+10;
const int mod=1e9+7;
using namespace std;
int main(int argc, char const *argv[])
{
	ios::sync_with_stdio(false);
	int a,b,n;//b>=a
	while(cin>>a>>b>>n)
	{
		int ca=0;
		int cb=0;
		/**
		 * 這裡不加特判也可以,但是最後的兩個if的順序要改變一下
		 */
		if(n==a)
		{
			cout<<"fill A\nsuccess"<<endl;
			break;
		}
		if(n==b)
		{
			cout<<"fill B\nsuccess"<<endl;
			break;
		}
		while(1)
		{
			if(ca==0)
			{
				ca=a;
				cout<<"fill A"<<endl;
			}
			else if(ca+cb<=b)
			{
				cb+=ca;
				ca=0;
				cout<<"pour A B"<<endl;
			}
			else
			{
				ca=ca-(b-cb);
				cb=b;
				cout<<"pour A B"<<endl;
			}
			if(cb==b)
			{
				cout<<"empty B"<<endl;
				cb=0;
			}
			if(cb==n)
			{
				cout<<"success"<<endl;
				break;
			}
		}
	}
	return 0;
}