1. 程式人生 > >Fence Repair STL——優先隊列

Fence Repair STL——優先隊列

sub class The creat pair tput pac different while

題目描述:

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li

). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn‘t own a saw with which to cut the wood, so he mosies over to Farmer Don‘s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn‘t lend FJ a saw but instead offers to charge Farmer John for each of the N

-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

輸入:

Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

輸出:

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

樣例:

Sample Input

3
8
5
8

Sample Output

34
註釋:
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8.
The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5
instead, the second cut would cost 16 for a total of 37 (which is more than 34).
題目大意:
農夫需要N段長度分別為L1,L2...的木板,但他只有一段長度為所需木板總長度的木板,他找到農夫Don幫他鋸開,每鋸一次就按被鋸的木板長度收一次費,求農夫的最小花費。
代碼:
#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
priority_queue<long long int,vector<long long int>,greater<long long int> > len;
int main(){
    long long int num,temp;
    scanf("%lld",&num);
    for(int i=0;i<num;++i){
        scanf("%lld",&temp);
        len.push(temp);
    }
    num=0;
    while(1){
        temp=len.top();
        len.pop();
        if(len.empty()) break;
        temp+=len.top();
        len.pop();
        len.push(temp);
        num+=temp;
    }
    printf("%lld",num);
    return 0;
}

這道題目用到了優先隊列

priority_queue

聲明:

priority_queue<Type, Container, Functional>

其中Type 為數據類型,Container為保存數據的容器,Functional 為元素比較方式

目前還是有點迷惑,感覺container是存放隊列的容器,然後functional就是類似於sort函數中的cmp的作用。

本題中定義的優先隊列和普通隊列不一樣的就是,將入隊的元素自動按從小到大的順序排序,隊頂為隊列中最小的元素,將所需的木板長度入隊,每次從隊首取出最短的兩塊木板合成為更長的木板,這樣就可以保證每次切割木板都是最小的情況,再將每次合成後的木板長度累加,即得答案。

關於優先隊列的一些博文啟發:

https://www.cnblogs.com/Deribs4/p/5657746.html

https://www.cnblogs.com/xzxl/p/7266404.html

Fence Repair STL——優先隊列