1. 程式人生 > >杭電acm第1003題Max Sum ( 動態規劃)

杭電acm第1003題Max Sum ( 動態規劃)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 169492    Accepted Submission(s): 39562


Problem Description Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input 2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output Case 1: 14 1 4 Case 2: 7 1 6 說明:  動態規劃 求  最大子序列 的和
  且最大   以及  最大子序列的  起始  和  終止  位置 已AC原始碼:
#include<stdio.h>
int main()
{
    int T,N,i,j,start,end,max,num,sum,temp;
    scanf("%d",&T);
    for(j=0;j<T;j++)
    {
        max=-1001;
        temp=1;
		sum=0;
        scanf("%d",&N);
        for(i=0;i<N;i++)
        {
            scanf("%d",&num);
            sum+=num;
            if(sum>max)
            {
                max=sum;
                start=temp;
                end=i+1;
            }
            if(sum<0)
            {
                sum=0;
                temp=i+2;
            }
        }
        printf("Case %d:\n%d %d %d\n",j+1,max,start,end);
        if(j<T-1)
        printf("\n");
    }
    return 0;
}