1. 程式人生 > >hdu 1028 Ignatius and the Princess III ( 母函式)

hdu 1028 Ignatius and the Princess III ( 母函式)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12606    Accepted Submission(s): 8903


Problem Description "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input 4 10 20
Sample Output 5 42 627 母函式 程式碼
#include<stdio.h>
#include<iostream>
#define MAXN 310
using namespace std;
int main()
{
    int temp[MAXN],ans[MAXN];
    int i,m=200,j,k,n;
    for(i=0; i<=m; i++)
    {
        ans[i]=1;
        temp[i]=0;
    }
    for(i=2; i<=m; i++)
    {
        for(j=0; j<=m; j++)
            for(k=0; k+j<=m; k+=i)
            {
                temp[k+j] += ans[j] ;
            }
        for(j=0; j<=m; j++)
        {
            ans[j] = temp[j];
            temp[j] = 0;
        }
    }
    while(cin >> n&&n)
    {
        cout << ans[n]<< endl;;
    }
    return 0;
}