1. 程式人生 > >HDU 1028 Ignatius and the Princess III(DP,整數劃分)

HDU 1028 Ignatius and the Princess III(DP,整數劃分)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22498    Accepted Submission(s): 15713


Problem Description "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input 4 10 20
Sample Output 5 42 627
Author

Ignatius.L

剛開始的時候,我一直以為這是一道純數學規律題,天真的以為可以一行公式程式碼ac,後來發現確實找不到規律QAQ;

再仔細分析一下題目,覺得這應該是一道DP題,因為大數的結果是和其往下分的小數密切相關的,所以就成了一道整數劃分題;

狀態轉移方程:dp[i][j]=dp[i][j-1]+dp[i-j][j];(dp[i][j]表示將i進行劃分,最大的數不超過j的方案個數);

於是題目變得非常簡單。

#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;
int dp[122][122];
int main(){
    for(int i=0;i<122;i++)
        dp[i][1]=dp[1][i]=dp[0][i]=1;
    for(int i=2;i<122;i++){
        for(int j=2;j<122;j++){
            if(j<=i)
                dp[i][j]=dp[i][j-1]+dp[i-j][j];
            else
                dp[i][j]=dp[i][i];
        }
    }
    int n;
    while(~scanf("%d",&n)){
        printf("%d\n",dp[n][n]);
    }
    return 0;
}