1. 程式人生 > >Oil Deposits (hdu 1241) (基礎dfs)

Oil Deposits (hdu 1241) (基礎dfs)

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42649    Accepted Submission(s): 24739

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

0 1 2 2

Source

(dfs求連通塊)怎麼看著這麼熟悉呢!原來是紫書上的一道例題……直接見註釋吧

#include<bits/stdc++.h>
using namespace std;
const int maxn=100+5;
char Map[maxn][maxn];
int m,n,flag[maxn][maxn];
void dfs(int r,int c,int id)
{
    if(r<0||r>=m||c<0||c>=n) return ;//出界的格子
    if(flag[r][c]||Map[r][c]!='@') return ;//不是'@'或者已經訪問過的格子
    flag[r][c]=id;//連通分量編號
    for(int i=-1;i<=1;i++)//搜尋相鄰及其對角線
        for(int j=-1;j<=1;j++)
        if(i||j) dfs(r+i,c+j,id);
}
int main()
{
    while(scanf("%d%d",&m,&n)==2&&m)
    {
        for(int i=0;i<m;i++) scanf("%s",Map[i]);
        memset(flag,0,sizeof(flag));
        int ans=0;
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            if(!flag[i][j]&&Map[i][j]=='@') dfs(i,j,++ans);
        printf("%d\n",ans);
    }
    return 0;
}