1. 程式人生 > >Til the Cows Come Home(最短路,注意重邊)

Til the Cows Come Home(最短路,注意重邊)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

這道題是求最短路問題,點到點,需要注意的是可能有重邊,要比較一下:

很明顯,我感覺用鄰接矩陣更簡單一點,臨界表感覺好麻煩。。我看了一下旁邊的,他鄰接表真的有點麻煩。。。

#include<stdio.h>
#include<string.h>
#include<math.h>

#include<queue>
#include<stack>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;

#define ll long long
#define da    10000000
#define xiao -10000000
#define clean(a,b) memset(a,b,sizeof(a))


int shuzu[1005][1005];
bool biaoji[1005];
int shuaxin[1005];
int n,t; 

void prime(int x)
{
	int i,j;
	for(i=0;i<1005;++i)
		shuaxin[i]=da;
	shuaxin[x]=0;
	for(i=1;i<=n;++i)
	{
		int can=-1,min=da;
		for(j=1;j<=n;++j)
		{
			if(biaoji[j]==0&&shuaxin[j]<min)
			{
				can=j;
				min=shuaxin[can];
			}
		}
		if(can==-1)							//如果can不變的話說明沒有可供選擇的路了 
			break;
		biaoji[can]=1;
		for(j=1;j<=n;++j)
		{
			if(biaoji[j]==0&&shuzu[can][j]+shuaxin[can]<shuaxin[j])		//如果中間繞一下比直接去更短 
				shuaxin[j]=shuzu[can][j]+shuaxin[can];		//就重新整理路徑長度 
	}
	
}

int main()
{
	
	scanf("%d%d",&t,&n);
	int i,j;
	for(i=1;i<=n;++i)
	{
		for(j=1;j<=n;++j)
			shuzu[i][j]=da;
	}
	for(i=0;i<t;++i)
	{
		int s,e,l;
		scanf("%d%d%d",&s,&e,&l);
		if(shuzu[s][e]>l)					//如果同樣的路徑,但距離更短,使用短的 
		{
			shuzu[e][s]=l;					//雙向連通圖 
			shuzu[s][e]=l;
		}
	}
	prime(1);								//從第0個開始 
	printf("%d\n",shuaxin[n]);				//輸出點到點的距離 
	return 0;
}