1. 程式人生 > >【杭電oj1159】Common Subsequence

【杭電oj1159】Common Subsequence

                             Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34234    Accepted Submission(s): 15611


Problem Description A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input abcfbc abfcab programming contest abcd mnp
Sample Output 4 2 0
Source
Recommend Ignatius   |   We have carefully selected several similar problems for you:  
1087
 1003 1058 1069 2084  最長公共子序列模板題:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
const int N = 1000;
char a[N],b[N];
int dp[N][N];
int main() {
    while(scanf("%s%s",&a,&b)!=EOF) {
        memset(dp,0,sizeof(dp));
        int lena=strlen(a);
        int lenb=strlen(b);
        for(int i=1; i<=lena; i++) {
            for(int j=1; j<=lenb; j++) {
                if(a[i-1]==b[j-1])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        printf("%d\n",dp[lena][lenb]);
    }
    return 0;
}